XMG 1.1 XFMG: Import From vBulletin 4.2 Albums

Dieses Thema im Forum "XenForo Add-on Support" wurde erstellt von paridus, 14. November 2015.

  1. paridus

    paridus Mitglied Lizenznehmer

    62
    10
    11. November 2015
    Erfurt
    Mein englisch ist nicht so gut deshalb versuche ich es hier mal:

    Server Error
    Mysqli prepare error: Unknown column 'old_id' in 'field list'

    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 808
    5. Zend_Db_Adapter_Abstract->fetchPairs() in XenForo/Model/Import.php at line 351
    6. XenForo_Model_Import->getImportContentMap() in XenForo/Model/Import.php at line 395
    7. XenForo_Model_Import->getImportContentMapFromArray() in XenForo/Model/Import.php at line 408
    8. XenForo_Model_Import->getUserIdsMapFromArray() in XenGallery/Importer/vBulletin42x.php at line 308
    9. XenGallery_Importer_vBulletin42x->stepAlbums() in XenForo/Importer/Abstract.php at line 97
    10. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 187
    11. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 239
    12. XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 182
    13. XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 351
    14. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    Was ist das für eine Fehlermeldung und wie kann ich das Problem lösen?
     
  2. moby2006

    moby2006 ist öfters hier Lizenznehmer

    131
    51
    18. Juli 2015
    Du wollötest bestimmt was aus dem Vbulletin importieren und er kennt die Spalte 'old_id' nicht.
    ich denke wenn du die in der Datenbank anlegst müsste es gehen.
    Sicher bin ich mir aber nicht

    Google Übersetzer
     
  3. paridus

    paridus Mitglied Lizenznehmer

    62
    10
    11. November 2015
    Erfurt
    Wo muss ich die denn anlegen?
     
  4. otto

    otto AD Lizenznehmer

    2.716
    1.102
    7. Juli 2015
    LW-Meister
    Leipzig
    Die wird in der Tabelle field_list vermisst. Gab es zuvor schon mal nen Import?
     
  5. paridus

    paridus Mitglied Lizenznehmer

    62
    10
    11. November 2015
    Erfurt
    Ich habe es mehrfach versucht es kam immer wieder der selbe Fehler. Kannst du mir Bitte sagen im welcher Tabelle ich das eintragen muss?
     
  6. au lait

    au lait Administrator Lizenznehmer

    1.904
    940
    7. Juli 2015
    Singen
    Es scheint als gäbe es Problem mit der IMPORT_LOG_TABLE - so zumindest laut der FehlerCodes oben
    Liegt in der DB eine Table mit einem Namen ähnlich IMPORT_LOG_TABLE und gibt es in dieser 3 Felder von der eine "old_id" lautet?
     
  7. paridus

    paridus Mitglied Lizenznehmer

    62
    10
    11. November 2015
    Erfurt
    Ja es gibt eine Tabelle xf_import_log mit den Feldern:

    • content_type
    • old_id
    • new_id
     
  8. McAtze

    McAtze ist öfters hier Lizenznehmer

    236
    234
    10. Juli 2015
    Gibt es denn eine Tabelle field_list und gibt es das Feld old_id dort auch?
     
    au lait gefällt das.
  9. paridus

    paridus Mitglied Lizenznehmer

    62
    10
    11. November 2015
    Erfurt
    Tabelle sieht nun so aus:
    Code:
    --
    -- Tabellenstruktur für Tabelle `xf_import_log`
    --
    
    CREATE TABLE IF NOT EXISTS `xf_import_log` (
      `content_type` varbinary(25) NOT NULL,
      `old_id` varbinary(50) NOT NULL,
      `new_id` varbinary(50) NOT NULL,
      PRIMARY KEY (`content_type`,`old_id`)
    ) ENGINE=InnoDB DEFAULT CHARSET=utf8;
    
    /*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
    /*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
    /*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;
    
     
  10. paridus

    paridus Mitglied Lizenznehmer

    62
    10
    11. November 2015
    Erfurt
    kann mir wirklich keiner helfen?
     
  11. McAtze

    McAtze ist öfters hier Lizenznehmer

    236
    234
    10. Juli 2015
    Steht denn in den Feldern was drin oder sind die leer?
     
  12. paridus

    paridus Mitglied Lizenznehmer

    62
    10
    11. November 2015
    Erfurt
    Die Felder sind leer.
     
  13. McAtze

    McAtze ist öfters hier Lizenznehmer

    236
    234
    10. Juli 2015
    Dann wirst du wohl nicht umhin kommen diesen Fehler bei XenForo zu melden .. (Media Gallery Support)
     
    au lait gefällt das.
OK Mehr Informationen

Diese Seite verwendet Cookies. Mit Deinem Klick auf OK, stimmst Du dem setzen von Cookies zu. Andernfalls werden keine gesetzt, was die Funktionalität einschränkt.